新闻  |   论坛  |   博客  |   在线研讨会
修改ubuntu系统下Python的版本和安装正确需要的依赖包
machinnneee | 2020-02-03 19:31:54    阅读:4509   发布文章

安装完系统,发现默认的python版本为2.7,为了使用最新的python版本,做个记录。主要是使用python链接下。

步骤如下:

pi@bpi-iot-ros-ai:~$ uname -a

Linux bpi-iot-ros-ai 4.4.55-BPI-M2P-Kernel #1 SMP PREEMPT Thu Nov 8 15:53:56 CST 2018 armv7l armv7l armv7l GNU/Linux

也可以 lsb_release -a 查看。


pi@bpi-iot-ros-ai:~$ py

py3clean           pydoc3             python2.7          python3-config

py3compile         pydoc3.5           python2.7-config   python3m

py3versions        pygettext          python2-config     python3m-config

pybuild            pygettext2.7       python3            python-config

pyclean            pygettext3         python3.5          pyversions

pycompile          pygettext3.5       python3.5-config   

pydoc              python             python3.5m         

pydoc2.7           python2            python3.5m-config  

在该目录下 添加最后一行

~/.bashrc

alias python='/usr/bin/python3.5'

之后sourse更新下:

pi@bpi-iot-ros-ai:~$ gedit ./.bashrc 

pi@bpi-iot-ros-ai:~$ source ./.bashrc 

pi@bpi-iot-ros-ai:~$ python --version

Python 3.5.2


注意:Python的版本查询为 python --version

现在使用的python为3.5版本,那么需要安装python3-matplotlib的依赖包。

如果安装不正确,会提示 No module named matplotlib 的错误。

sudo apt-get install python3-matplotlib




*博客内容为网友个人发布,仅代表博主个人观点,如有侵权请联系工作人员删除。

参与讨论
登录后参与讨论
sugar6666  2020-02-04 12:04:01 

学习了,谢谢

推荐文章
最近访客